Activation Module Bidder is unavailable

Incident Report for Equativ Maestro

Resolved

Dear Customers,

We are pleased to inform you that the delivery issue with the Maestro Activation Bidder has been resolved.

Start date & time: Jul 17, 2026, 10:10 AM UTC
End date & time: Jul 17, 2026, 11:55 AM UTC

Thank you for your patience during this time.

#INC-1570
Posted Jul 17, 2026 - 14:41 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 17, 2026 - 13:51 UTC

Identified

Dear Customer,

We have identified an issue with the Maestro Activation bidder. As this issue may result in campaigns experiencing under-delivery or over-delivery, we have taken the precautionary measure of pausing bidding while we work to resolve it.

Start date and time: Jul 17, 2026, 10:10 AM UTC

We apologize for any inconvenience this may cause and appreciate your patience and understanding while we address this issue.

#INC-1570
Posted Jul 17, 2026 - 13:45 UTC
This incident affected: Delivery US and Delivery EMEA / APAC.