Maestro Unavailable

Incident Report for Equativ Maestro

Resolved

This incident has been resolved. Sorry for the inconvenience.
Posted Apr 20, 2026 - 16:07 UTC

Investigating

Dear Customer,

Maestro platform is currently unavailable.
Our team is actively working to resolve the issue and restore full functionality as quickly as possible.
We appreciate your patience and understanding and apologize for any inconvenience
Posted Apr 20, 2026 - 14:06 UTC
This incident affected: Maestro UI.