No more data displayed on Instant Insights and Maestro

Incident Report for Equativ Maestro

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 11:21 CET

Update

Dear Customer,

Our technical team has identified the issue that affected data availability starting on 30 Oct 2025, 15:30 (UTC). Data is now visible again on the platform as of around 16:15 (UTC).

You may still experience slightly longer loading times while the system continues to stabilize. Our engineers are closely monitoring the situation and applying further adjustments to ensure full performance is restored as soon as possible.

We appreciate your patience and understanding as we complete this process.

#INC-1400
Posted Oct 30, 2025 - 20:11 CET

Update

Dear Customer,

Our technical team has identified the issue that affected data availability on October 30, starting around 4:30 PM CET. Data is now visible again on the platform; however, you may still experience slightly longer loading times as the system continues to stabilize.

Our engineers are closely monitoring the situation and applying further adjustments to ensure full performance is restored as soon as possible.

We appreciate your patience and understanding while we continue to work on this.
Posted Oct 30, 2025 - 19:41 CET

Monitoring

Dear Customer,
We are currently experiencing an issue that may cause some data to be temporarily unavailable in the platform on October 30, starting around 4.30pm CET. Our technical team has already identified the root cause and is actively working on a fix.

At this time, our engineers are monitoring the situation and applying the necessary corrections to restore full functionality as soon as possible.

Thank you for your understanding and patience.

#INC-1400
Posted Oct 30, 2025 - 19:28 CET
This incident affected: Maestro UI and Reporting.