Limited access to Maestro Platform

Incident Report for Equativ Maestro

Resolved

Dear Customers,

We are pleased to inform you that the issue on accessibility of Maestro Platform has been resolved.

Start date & time: September 04, 2026 at 09:16:00 AM UTC
End date & time: September 04, 2026, at 09:56:00 AM UTC

We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding.

#inc-1603
Posted Sep 07, 2026 - 10:24 UTC

Monitoring

Dear Customers,

We have implemented a solution to the issue on accessibility of our Maestro Platform. We are closely monitoring the situation to ensure the issue is fully resolved.

Start date & time: September 04, 2026 at 09:16:00 AM UTC
End date & time: September 04, 2026, at 09:56:00 AM UTC

We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding.

#inc-1603
Posted Sep 04, 2026 - 13:56 UTC
This incident affected: Maestro UI.