Maestro unavailable

Incident Report for Equativ Maestro

Resolved

Dear Customers,

We have identified and mitigated an issue with Maestro. The platform was unavailable for about one hour on Saturday.

Start date & time: July 18th, 2026, at 5:30 PM UTC
End date & time: July 18th, 2026, at 6:49 PM UTC
Total duration of the incident: 1 hour 19 minutes.

We apologize for the inconvenience caused.

#inc-1572
Posted Jul 20, 2026 - 08:54 UTC

Monitoring

Dear Customers,

We have identified and mitigated an issue with Maestro. The platform was unavailable for about one hour on Saturday.

Start date & time: July 18th, 2026, at 5:30 PM UTC
End date & time: July 18th, 2026, at 6:49 PM UTC
Total duration of the incident: 1 hour 19 minutes.

We apologize for the inconvenience caused.

#inc-1572
Posted Jul 20, 2026 - 08:53 UTC
This incident affected: Maestro UI and Activation.