Activation Module Bidder partially unavailable in Europe

Incident Report for Equativ Maestro

Resolved

Dear Customers,

We have identified and mitigated the issue that partially impacted the Activation Module Bidder in Europe:

Start date & time: May 27th, 2026, at 9:30PM UTC
End date & time: May 28th, 2026, at 3:30AM UTC
Total duration of the incident: 6 hours.

We apologize for the inconvenience caused.

#inc-1538
Posted May 28, 2026 - 07:52 UTC

Identified

Dear customer,

The bid activation module is currently experiencing partial unavailability in Europe due to a technical issue identified at 08:00 PM UTC.

As a result, some campaigns may experience underdelivery.

Our team is actively investigating and working to restore full functionality as quickly as possible.

We apologize for the inconvenience and will provide updates as more information becomes available.

#INC-1538
Posted May 27, 2026 - 20:41 UTC
This incident affected: Activation.