Missing data in Maestro reporting tools

Incident Report for Equativ Maestro

Resolved

Dear Customer,

After completing the data recovery process, we identified an issue that resulted in the permanent loss of data generated between 6 am and 8 am CET 29th October. This incident occurred in our largest data center and resulted in an estimated 33% data loss during the 2h period.

Also, between 6 am CET 29th October and 4am CET 30th October, you may have noticed inaccurate or delayed RTB/programmatic data across all reporting tools while the recovery was taking place.

Our teams have stabilized all systems and are implementing additional safeguards to prevent similar occurrences in the future.

We sincerely apologize for the inconvenience and appreciate your understanding.

#inc-1399
Posted Oct 30, 2025 - 10:21 CET

Update

Dear Customer,

The incident has been resolved and the data is being recovered.

We will share an update on the recovery tomorrow at 10 CET.

We thank you for your understanding and apologize for the inconvenience.

#inc-1399
Posted Oct 29, 2025 - 16:14 CET

Identified

Dear Customer,

You may observe inaccurate or late data on all Maestro reporting tools since 6am CET 29th October.

Our technical teams are investigating the issue in order to return the service as soon as possible.

#inc-1399
Posted Oct 29, 2025 - 10:18 CET
This incident affected: Reporting.