Missing RTB Reporting Data on Maestro & EMP Instant Insights

Incident Report for Equativ Maestro

Resolved

Dear Customers,

We are pleased to inform you that the reporting issue resulting in data loss in RTB has been resolved. Data recovery has been completed.

Start date & time: June 2nd, 2026, at 10:00 AM UTC
End date & time: June 3rd, 2026, at 02:16 PM UTC

Thank you for your patience during this time.

#inc-1543
Posted Jun 05, 2026 - 13:30 UTC

Identified

Dear Customers,

We have identified a reporting issue where we observe Data Loss in RTB starting on June 02. The platforms affected are Maestro and EMP Instant Insights (IRB not impacted). Our team is actively working to fix this as soon as possible.

Start date & time: June 2nd, 2026, at 10:00 AM UTC

We apologize for the inconvenience caused. Thank you for your patience.

#inc-1543
Posted Jun 03, 2026 - 08:02 UTC
This incident affected: Reporting.